제작하기소스공유
웹 제작시 도움이 되는 유용한 팁을 나눌 수 있습니다. 답변을 구하는 글은 [물어보기]를 이용해주세요.
조회 수 347 추천 수 3 댓글 28
?

단축키

Prev이전 문서

Next다음 문서

크게 작게 댓글로 가기 첨부
?

단축키

Prev이전 문서

Next다음 문서

크게 작게 위로 아래로 댓글로 가기 첨부

2016-12-30_9-22-09.png



OS 버전 : CentOS6.8 Minimal 설치

APM 버전 : Apache 2.4.25 , MariaDB 10.1.20, PHP 5.6.29

테스트 : 32bit PC

 

OS 버전 : CentOS7 Minimal 설치

APM 버전 : Apache 2.4.25 , MariaDB 10.1.20, PHP 7.1.0

테스트 : 64bit PC

 

압축을 푸시면 설치 설명서 동봉 하오니 자동설치후에 참고하여 수정해 주셔야 정상작동 합니다.

설치시 문제가 있거나 오류 발생시 댓글주시면 살펴 보도록 하겠습니다.

 

출처 : nanoomi.org

  • profile
    프렌다 2016.12.31 00:19:39
    수고 많으셨습니다!!
  • profile
    아파치 2016.12.31 00:36:44
    감사합니다.
  • profile
    포커스 2016.12.31 00:26:32
    수고 많으셨습니다~ 이것으로 보다 편리하게 APM 설치가 가능해질 것 같네요 ^^
  • profile
    아파치 2016.12.31 00:37:11
    조금이라도 도움이 되었으면 좋겠습니다.....^^
  • profile
    기진곰 2016.12.31 00:33:58
    예고하셨던 스크립트가 드디어 나왔군요!

    다 좋은데 마지막에 reboot가 마음에 걸립니다. 스크립트 돌려 놓고 커피 한 잔 하고 오라고 해두셨는데, 자리에 돌아와 보니 서버가 재부팅되어 중간에 떴던 에러메시지도 확인할 수 없게 되면 곤란할 듯...
  • profile
    아파치 2016.12.31 00:39:31

    재부팅되기 전에 에러날 부분은 APM 소스 설치부분인데
    다운로드가 안되거나 에러가 출력되면 download fail 또는 install fail 되면서 멈추게 했습니다...^^

    물론 그것까지 테스트 했구요.

  • ?
    팀9 2016.12.31 06:01:33
    와 아파치님... 서버 전문가신듯!! ㅋㅋ 멋져요!
  • profile
    아파치 2016.12.31 06:35:30
    감사합니다.
    서버 전문가는 @기진곰 님이시고 저는 취미로 공부중이랍니다....^^
  • ?
    팀9 2016.12.31 06:43:42

    기진곰님은 1월부터 휴가를 떠나신다고 합니다.
    따뜻한 나라로 여행을 가시는 듯 하네요 ㅠㅠ

  • profile
    아파치 2016.12.31 08:41:08
    전 지금이 휴가중인데 이러고 있네요....ㅠㅠ
  • ?
    진영 2016.12.31 09:55:10
    와 감사합니다~!
  • profile
    아파치 2016.12.31 13:50:53
    조금이라도 도움이 되셨으면 좋겠습니다.
  • profile

    좋은자료 감사합니다.
    설치중에 에러가 발생하여 어떻게 해결해야 하는지 궁굼해서요
    php7.1.0 install fail이 라고 마지막에 나오는데요

    제목 없음-2.png

    어떻게 해결할수있는지 궁굼합니다.

  • profile
    아파치 2016.12.31 17:20:10

    MySQL 설치중에 문제가 있었던 모양 입니다. 재설치 하라고 나오네요.
    서버 환경이 어떻게 되나요? 설치OS버전,CPU,램 크기등등....

  • profile
    우리아기 2016.12.31 17:29:51
    CPU: 1 vCore
    RAM: 768 MB
    Storage:15 GB SSD

    centos-release-7-3.1611.el7.centos.x86_64
    epel-release-7-8.noarch

    입니다.
  • profile

    2016-12-31_5-59-06.png

    VMware 에 같은 환경을 만들고 테스트 해보았는데 이상없이 설치 되었습니다.

    APM이 기존에 설치된 환경이었거나 다른작업으로 인하여 메모리가 부족해서 생긴것은 아닐까 생각해 봅니다.

     

    최초 CentOS7 minimal 상태로 스크립트를 시작해야 정상설치가 가능 할것으로 사료 됩니다.

     

     

  • profile
    우리아기 2016.12.31 20:12:36
    vps에서 minimal로 설치를 안해주었나보군요...
    재 컴퓨터에 같은 상태로 minimal 해봤는데 설치가 잘 되느군요...
    혹시 httpd -v 와 php -v 로 버전 확인은 안되나요? httpd는 확인이 안되는데 php 같은 경우는 5.4인가로 나오더라구요
  • profile

    지금 php -v 로 확인해보니 정말 php 5.4.16 으로 나오네요....ㅠㅠ
    아마도 php 버그인것 같습니다.

    phpinfo.php 만들어 호출하니 정상적으로 출력이 되네요. 어찌 이런일이......

     

    2016-12-31_6-53-31.png

     

    2016-12-31_6-55-55.png

  • profile
    우리아기 2016.12.31 21:00:02
    httpd와 mysql(MariaDB) 버전도 phpinfo 말고 리눅스 콘설에서 확인이 되었으면 합니다 ^^
  • profile
    아파치 2016.12.31 21:03:59

    httpd -v 와 php -v 로 버전 확인은 /root/.bash_profile 파일을 에디터로 열고 아래 구문을 PATH=$PATH:$HOME/bin

    아래와 같이 바꾸고 저장해 주세요.
    PATH=$PATH:$HOME/bin:/usr/local/mariadb/bin:/usr/local/apache/bin:/usr/local/php/bin

    그후에 쉘에서 source /root/.bash_profile 한번 실행해 주시면 작동이 가능 할겁니다.

     

    스크립트를 잘못 적용한것 같네요...^^;;

    다음버전에는 수정해서 올려 보겠습니다.

  • profile
    우리아기 2017.01.02 23:18:29

    1. 텍스트 파일 있는데로 수정하고 XE설치하려고 업로드 하니 500 에러가 발생합니다.

    (다른것도 문제인가 싶어 워드프레스도 업로드 해봤으나 워드프레스는 정상 작동 합니다.)

     

    2. Let's Encrypt 인증서 설치시 /etc/httpd 가 기본인지 /usr/local/apache쪽을 못잡습니다.

  • profile
    아파치 2017.01.03 15:04:51
    xe가 PHP7.1.0 에서 작동 하나요? 뭔저 그걸 확인 해 보셔야 할겁니다.
    그리고 Let's Encrypt 는 경로를 잡아주어야 정상적으로 작동 할 것 같네요.
  • profile
    YJSoft 2017.01.03 15:16:21
    XE는 PHP7.1 환경을 아직 지원하지 않습니다.
  • profile
    구미호 2017.01.07 20:23:13
    고생 많으셨네요 ㅎㅎ
  • profile
    Sunup 2017.01.08 01:22:23
    우 우 우!! 우분투 버전도!!!
    고생 많으셨습니다!!
  • profile
    우리아기 2017.01.12 17:46:15
    mod_http2.so는 어떻게 해야 나올까요?
  • profile
    아파치 2017.01.26 06:03:18

    httpd.conf 에 아래와 같은 구문이 없다면 리빌드 하셔야 합니다.

    #LoadModule http2_module modules/mod_http2.so

    있다면 #을 제거하고 아래 내용을 추가하시고 리스타트 해주시면 됩니다.

    <IfModule http2_module>
    LogLevel http2:info
    </IfModule>
    #Enable HTTP/2 support
    Protocols h2 http/1.1

     

    mod_http2.so 설치는 아래와 같습니다.

     

    # wget https://github.com/icing/mod_h2/releases/download/v1.8.9/mod_http2-1.8.9.tar.gz

    # tar -zxvf mod_http2-1.8.9.tar.gz

    # cd mod_http2-1.8.9

    # ./configure --with-apxs=/usr/local/apache/bin/apxs

    # make && make install

  • ?
    별하 2017.01.16 18:44:55
    감사합니다 잘사용하도록하겠습니다.

서버에 요청 중입니다. 잠시만 기다려 주십시오...