XETOWN

호수 공원

XE 사용에 대한 여러가지 정보들을 공유할 수 있습니다.
조회 수 271 추천 수 7 댓글 13
?

단축키

Prev이전 문서

Next다음 문서

크게 작게 댓글로 가기 인쇄 첨부
?

단축키

Prev이전 문서

Next다음 문서

크게 작게 위로 아래로 댓글로 가기 인쇄 첨부

pr_pause_gif_v0.2.1.zip

 

달라진점

- 홈페이지 주소에 xe가 포함된 경우에도 대응하도록 수정 되었습니다. 예)http://www.test.com/xe

- 홈페이지 운영도중 ssl을 적용한경우 https상태에서 http로 이미지를 호출하는 경우가 있어서 이를 대비해 사용된 이미지가 내 사이트의 첨부파일인 경우 링크 주소에서 http(s)을 제거하고 사용합니다. 예) src="http://이미지 링크" -> src="//이미지 링크"

- 모바일 전용 옵션이 추가 되었습니다. 모바일 전용 옵션을 활성화 하면 PC사용자가 게시글을 열람할 경우에는 섬네일을 생성하긴 합니다만 섬네일이 아닌 원본 이미지를 그대로 보여줍니다.

- 모바일에서 버튼 중앙 정렬이 누락되는 경우가 발견되어 스크립트를 약간 변경 했습니다.

- 섬네일생성시 안정성을 높이기위해 조건문을 몇가지 추가 했습니다.

 

추가로 XE + 이미지 프로세스 모듈 환경에서도 작동하는것을 확인 했습니다. 물론 다양한 서버환경이나 다양한 옵션에서 테스트한것이 아니기 때문에 정답이 아닐수는 있습니다.

 

  • profile
    웹지기 2017.02.02 21:28:31
    외부 이미지는 소스에 적힌 주소 그대로 불러오게 되어있는거죠? http(s)

    설명에 있었네요. 내 사이트에 첨부된 경우라고...
  • profile
    prologos 2017.02.02 21:31:20

    네, 외부 이미지가 링크된경우는 그대로두고 내 사이트의 경우만 http(s)를 지워서 사용합니다.

  • ?
    기븐 2017.02.03 00:40:15

    적용하고 나니까 원본 이미지는 원본 이미지대로 그대로 나오고 그 아래에 썸네일 이미지가 한번 더 나오네요. 결과적으로 똑같은 사진이 두번 나옵니다. (모바일 전용, 작동 방식 옵션들 조절해봐도 마찬가지네요)

     

    라이믹스 develop 최신버전이고 php 7.1입니다.

     

    글구 댓글에 업로드된 파일은 적용이 안 되는거 같네요. XE에서는 댓글로도 첨부가 가능한 만큼 댓글에도 적용이 필요할 것 같습니다.

  • profile
    prologos 2017.02.03 17:52:51
    어디선가 이 애드온이 작성한 태그요소들을 변경하는 모양이네요. 댓글 적용은 생각해 보겠습니다.
  • profile
    고라자 2017.02.03 02:11:36
    적용 후에 플레이버튼까지는 나오지만, 플레이버튼을 클릭해도 아무 반응이 없습니다.

    라이믹스 develop 최신 버전이고, apache 최신버전 + php7.1 환경입니다.
  • profile
    prologos 2017.02.03 17:45:32
    버튼 눌렀을때 치환작업은 자바 스크립트가 하는데 작동이 안한다면... 필요한 태그요소가어디선가 지워졌거나 스크립트 오류일 가능성이 있네요. 어떤 오류인지 한번 살펴보세요.
  • profile
    고양이 2017.02.03 09:32:06
    너무 좋습니다!
  • profile
    웹지기 2017.02.03 11:15:01

    저희는 버튼이 가운데 정렬이 안되는 현상이 가끔 있는건 있지만 이상없이 잘 동작하네요.
    XE최신버전입니다. php는 5.5.9 이구요.

  • profile
    고양이 2017.02.03 17:07:57 Files첨부 (1)

    pc.jpg

    이번 버전은 PC에서 마우스 오버하니 재생버튼이 안나오고 ㅎㅎ 글이 뒤집히네요 ~

    기능은 정상입니다. ~

  • profile
    prologos 2017.02.03 17:48:11
    음... 아마 ie에서 그런현상이 있을꺼에요. 제가 크롬과 엣지에서만 테스트를 했었는데 ie로 접속해보니 그렇더라구요.
  • profile
    웹지기 2017.02.03 17:49:38
    IE 구버전에서 있는 현상인가봅니다. IE11 에서 저희 사이트는 정상이네요.
  • ?
    alrin 2017.02.04 21:33:24
    좋은 자료 고맙습니다!
    댓글에서도 적용됐으면 좋겠네요.
  • ?
    식이 2017.02.04 21:51:07
    멋져요!

위로
서버에 요청 중입니다. 잠시만 기다려 주십시오...