카페24에서 임대서버를 사용하고 있습니다.

mysql 버전을 확인해보니 5.1대 버전이더군요.

 

fulltext index를 사용하려면 버전업이 필요한데

기왕이면 5.7대 버전으로 업그레이드를 생각하고 있습니다.

 

dev.mysql.com에서 lunux-generic 파일은 다운받아놓았는데...

mysql dump를 떠놓긴 했는데 그 다음에 어떻게 해야할지 처음이라서 무섭네요.

 

1. 기존 mysql을 삭제하고 5.7 다운받은 것을 새롭게 깔면 되는 것인가요?

 

(그러하다면)

2. 소스설치(컴파일) 설치된 프로그램은 어떻게 삭제해야하나요?

 

(그렇지 않다면)

2. 기존 mysql이 깔려있는데도 5.7을 새롭게 깔아도 되나요?

3. 새로운 디렉토리가 아닌 기존 디렉토리를 그대로 사용하고 싶은데, 문제가 없나요?

 

등등...

조언 주시면 감사하겠습니다 ㅠ

 

 

 

 

 

  • profile
    기진곰 2016.06.09 16:33:29

    1. 소스 컴파일하지 마세요.

     

    2. 소스 컴파일하지 마세요.

     

    3. 소스 컴파일하지 마세요.

     

    4. 만약 사용하시는 리눅스가 Gentoo, Slackware 등 원래 소스 컴파일을 많이 시키는 배포판이라면 위의 1~3번은 무시하셔도 됩니다. 그러나 그런 리눅스 배포판을 사용하시는 분이라면 여기서 묻지도 않겠죠...

     

    5. Ubuntu라면 적당한 PPA를 추가하기만 하면 apt-get으로 설치 및 업데이트할 수 있습니다.

    https://launchpad.net/~ondrej/+archive/ubuntu/mysql-5.7

     

    6. CentOS라면 MySQL에서 공식 제공하는 repo를 추가한 후 yum으로 설치 및 업데이트할 수 있습니다.

    https://dev.mysql.com/downloads/repo/yum/

     

    7. 아니면 그냥 MariaDB 쓰세요. 모든 저장엔진에서 fulltext 검색 지원 됩니다.

    https://downloads.mariadb.org/mariadb/repositories/

     

    8. 소스 컴파일하지 마세요.

     

    9. 소스 컴파일하지 마세요.

     

    10. 소스 컴파일하지 마세요.

  • ?
    SimpleCode 2016.06.09 18:10:42
    결론은 소스 컴파일하지 마세요ㅋㅋㅋㅋ
  • profile
    김웃김 2016.06.09 18:39:30
    ㅋㅋㅋ감사합니다...

서버에 요청 중입니다. 잠시만 기다려 주십시오...