웹호스팅에서 운영중인 사이트를 가상서버 호스팅으로 이전 운영을 해 보고자 무작정 시도중인 초보자입니다. 

 

1. 현재 운영중인 사이트 카페24 웹호스팅 서버정보

app : Apache / xe_version : 1.8.20 / php : 5.3.13p1 / db_type : mysql

 

2. 카페24 가상서버 호스팅을 신청해서 최종적으로는 웹호스팅 받던 백업 자료를 가져와서 셋팅을  하고자 합니다.

  이제 막 가상서버호스팅에 관해서는 웹을 통해 학습 중에 있구요. ^^;;

 

카페24 서버 호스팅을 신청하는 과정 중에 아래와 같은 선택사항들이 있는데 최종적으로 웹 호스팅 중이던 자료를 가상서버 호스팅으로 가져 온다라고 봤을 때 문제점이 생기지 않을지가 궁금합니다.

2016-06-29 10,54,21.JPG

os 우분투 최신 버젼 선택  / os만 설치 요청 후 apm은 위 웹호스팅 서버정보와 같은 버젼의 php 설치 / 보안설정은 사용으로 설치 요청하면 되는지가 궁금합니다. 

 

apm 카페24에 설치요청하거나 제가 직접 설치 시 apache, php, mysql 각각 최신 버젼으로 설치해도 xe 1.8.* 대 버젼이 문제가 없을런지도 궁금하구요.

 

 

이외에 가상서버호스팅을 이용 해 보신 분들 현재 버젼의 xe를 가상서버에서 돌리고자 할때 처음 가상서버를 접하는 초보자들이 참고 해야 할만한 사항 있으시면 조언 부탁드리겠습니다.

 

 

 

 

  • profile
    기진곰 2016.06.29 11:30:57

    XE 최신버전이라면 다른 것들도 모두 최신버전이 좋습니다. 사용하시던 버전과 같은 것으로 맞출 필요는 없습니다. 컴파일 옵션까지 똑같이 맞춘다고 삽질하는 분들을 가끔 보는데, XE는 범용성이 높기 때문에 공식적으로 발표된 최소 사양만 맞추면 나머지는 상관없습니다. 게다가 PHP 5.3과 5.6~7.0은 성능 차이가 몇 배나 납니다.

     

    직접 설치한다면 우분투니까 apt-get으로 설치하는 것을 말하시는 거겠지요? 만약 뭔가를 컴파일(make)하라고 하는 튜토리얼이 있다면 가볍게 무시해 주시면 됩니다. 카페24에서 APM 설치를 해주는 경우도 마찬가지로 유지관리가 곤란한 방식으로 설치됩니다. 우분투에서 뭔가를 설치한다면 무조건 apt-get이 답입니다.

     

    그런데 최신 버전이 우분투 12.04인가요? 그건 이제 몇 달 후면 지원이 종료되는 버전인데요 ㅡ.ㅡ

  • ?
    yoon 2016.06.29 11:52:09

    조언 진심으로 감사의 말씀 드립니다. ^^

    본문내 카페24 설치 옵션 이미지는 웹 서핑중의 발견된 이미지라 현재 시점과는 조금 차이 가 있을 것 같습니다.

    " 카페24에서 APM 설치를 해주는 경우도 마찬가지로 유지관리가 곤란한 방식으로 설치됩니다. 우분투에서 뭔가를 설치한다면 무조건 apt-get이 답"
    -> 카페24에 apm 설치 요청을 하는것 보다는 apt-get(? 이 부분은 검색을 해보도록 하겠습니다. ^^; ) 방식으로 직접 설치가 낮다라는 말씀으로 이해 하도록 하겠습니다.

     

    갈길이 멀지만 조언 주신대로 차근차근 한번 해봐야 겠습니다. ^^

  • profile
    놀리지마유 2016.06.29 11:41:09
    일단 최소한 XE 1.8.XX 를 사용하실려면 5.4 이상이 권장인데 PHP 5.6 까지는 기본적으로 고려해보시고
    약간의 수고를 하실 수 있다면 PHP 7.0.X 로 넘어감시는 것도 좋을것 같습니다.
    우분투는 14.04 나 16.04 LTS 로 설치하시면 될 거 같구요.
  • ?
    yoon 2016.06.29 11:53:36

    조언 감사의 말씀드립니다. ^^

    궁금했던 php 버젼은 말씀 해주신 것처럼 php 7.0.x 으로 , 우분투는 14.04 나 16.04 LTS  로 설치를 한번 해보도록 하겠습니다.

  • profile
    기진곰 2016.06.29 12:18:07

    우분투 16.04는 아랫분 댓글처럼 PHP 7.0.x가 기본입니다. 우분투 14.04는 PHP 5.5.x가 기본이고, 이 가이드를 따라하면 PHP 7.0을 설치할 수 있습니다.

     

    apt-get으로 설치하는 경우 버전 끝자리(x)의 차이는 신경쓰지 않아도 됩니다. 우분투에서 자체적으로 패치하는 부분이 몇 군데 있기 때문에 버전 끝자리가 조금씩 달라지고, 공식적인 최신 버전을 항상 따라가지는 않거든요.

  • ?
    yoon 2016.06.29 13:32:34
    넵 도움이 많이 되었습니다. 감사합니다 ^^
  • profile
    오징 2016.06.29 11:56:51
    기진곰님 댓글대로... OS가 저게 설치되는거라면 너무 구식...
    전 Vultr밖에 안써봤지만 16.04도 지원하는데...

    Vultr에 OS는 Ubuntu16.04로 설치하고
    apt-get 명령어만으로
    Nginx 1.10
    MariaDB 10.0.24
    PHP 7.0.4
    phpmyadmin 4.5.4.1
    로 세팅하고 (이러면 apt-get update,upgrade 명령어만 치면 업데이트 바로바로 된다는거 같아서..)
    라이믹스 깔아서 공부중인데....

    DB쪽은 구버전에서 신버전으로 올린다고 문제가 생기진 않을꺼같고
    사용하시던 모듈이나 애드온중에 php7에서 지원이 종료된 함수(?)같은걸 쓰는 부분이 있다면 문제가 있을수도 있지않을까요?
  • ?
    yoon 2016.06.29 12:09:19
    본문 내 삽입 참조 이미지는 현재 기준이 아니라 예전 기준의 자료를 잘못 올린 부분입니다. ^^;;
    사용중인 모듈이나 애드온 을 고려 해서 php버젼도 다시 한번 고려를 해봐야 겠군요.
    조언 말씀 감사합니다. ^^

서버에 요청 중입니다. 잠시만 기다려 주십시오...