XETOWN

질문/답변

웹에 관련된 질문과 답변을 나눌 수 있습니다.

이게 모두가 그런 건 아니고 유독 메뉴 한 군데서만 이러네요;;

 

1. 보시다시피 브라우저 제목이 한글로 되어 있죠. 사실 이것도 원래는 '메뉴 이름'에서처럼 다국어 입력을 해놨던 건데 자동으로 풀린 겁니다;;;

01.png

 

2. 증명을 위해 지구 모양 아이콘을 클릭하고 영어로 된 브라우저 제목을 입력해보겠습니다. 아래처럼 문제 없이 입력했죠.

02.png

 

3. 일단 관리자 페이지에서는 '브라우저 제목'에도 다국어 반영이 잘 되어 있는 걸 확인할 수 있습니다. 한국어 모드니까 태극기 아이콘이 떠 있는 거겠죠.

03.png

 

4. 이제 사이트로 오면 한국어 버전에서 잘 나오는 걸 볼 수 있습니다. (아포리아는 사이트 제목이에요ㅎㅎ) 왼쪽 그림은 한국어 버전으로 봤을 때고, 오른쪽 그림은 영어 버전으로 봤을 때예요. 영어 버전에서 다국어 기능이 풀렸죠?

04.png  05.png

 

5. 분명 소스에 문제는 없는데 말입니다.

06.png

 

6. 실제로 다시 사이트 메뉴 편집으로 가보면 '브라우저 제목'에 다국어 기능이 풀려 있는 걸 볼 수 있습니다. 영어 버전에서도, 한국어 버전에서도요ㅠㅠ

07.png08.png

 

 

다른 메뉴의 '브라우저 제목'은 다국어가 풀리지 않고 유독 '블로그'라는 제목만 이러네요.

사이트 메뉴에서 블로그 메뉴를 삭제하고 다시 생성을 해봐도 똑같은 과정이 반복되고 있구요...

 

저로서도 어찌된 영문인지 잘 모르겠는데, 혹시라도 도움주실 수 있으면 감사하겠습니다.

 

보탬: 근데 영어 버전의 아이콘이 미국 성조기인 건 좀 이상하지 않나요. English인데 성조기보다는 유니언잭이 더 어울릴 것 같아요.

  • profile
    기진곰 2016.08.04 19:40:48 Files첨부 (2)

    재현이 되지 않습니다.

     

    Untitled.pngUntitled2.png

  • profile
    윤삼 2016.08.04 20:08:00
    재현이 안 된다는 말씀은 저처럼 풀리거나 하는 일은 없으시다는 거죠? 훔...

    제가 가만 비교해보니 유독 이 메뉴만 풀리는 게 '영어를 기준으로 봤을 때' '메뉴 이름'과 '브라우저 제목' 그리고 '메뉴 ID'가 모두 동일할 때 그렇게 사라졌던 게 아닌가 싶어요. 다른 메뉴들은 메뉴 ID가 브라우저 제목과 서로 달랐거든요.

    브라우저 제목과 메뉴 ID 사이에 논리적으로 무슨 문제가 있나 싶기도 하네요. 특히 영어에서요.
  • profile
    기진곰 2016.08.04 19:46:15

    언어를 국기와 연결하는 것 자체가 사실 에러죠. 여러 언어를 사용하는 나라도 많고, 여러 나라에서 사용되는 언어도 많으니까요. 우리나라처럼 절대 다수의 국민들이 한 가지 언어를 사용하는 경우가 오히려 드뭅니다.

     

    영어도 원래 en_US, en_GB, en_CA, en_AU 등으로 나눠야 하는데 귀찮아서 그냥 미국식 스펠링만 쓰고 있어요. 스펠링을 따진다면 성조기가 맞을 듯 해요. 유니온잭을 붙여 주려면 칼라셋도 colourset이라고 써야죠 ㅋㅋㅋ

  • profile
    데버 2016.09.02 03:21:15
    일반 xe에서도 같은 현상이네요. 사이트 2개가 있는데 그 중 1개가 위와 같은 문제가 발생합니다. 어디서 잘못되었는지 감이 안오네요...
  • profile
    데버 2016.09.02 03:21:39
    저 같은 경우엔 모든 메뉴가 그럽니다.
  • profile
    윤삼 2016.09.02 14:07:38

    제가 테스트를 해보니 [게시판 관리]에서 '브라우저 제목'을 처음 설정하고 '등록'했을 땐 괜찮은데, 나중에 다른 설정을 수정하고 '등록' 버튼을 누르고 나면 '브라우저 제목'의 다국어가 풀리더라구요.
    데버님도 같은 방식으로 한번 테스트를 해주시겠어요?
    XE에서도 그런 현상이 확인된다면 라이믹스가 아니라 XE코어에 이슈로 등록을 하려구요.

  • profile
    데버 2016.09.02 16:36:14
    아마 저도 같은 현상으로 기억합니다. 특이한게 두 사이트중 한개에서만 그런 문제가 생깁니다. 어떠한 애드온이랑 모듈이랑 충돌이 아닌가 생각도 드네요.
  • profile
    윤삼 2016.09.02 16:39:00
    음, 그것도 한번 점검해봐야겠네요
  • profile
    윤삼 2016.09.03 11:55:49
    YJSoft님이 상황 확인을 해주셨으니 조만간 패치가 있을 것으로 보입니다.
    https://github.com/xpressengine/xe-core/issues/1955
  • profile
    데버 2016.09.03 12:10:03
    반가운 소식이네요. 그렇게까지 심각한 상황은 없어서 방치하고 있었는데 윤상님께서 대신해주셨네요. 감사합니다.

List of Articles
번호 분류 제목 최종 글
공지 질문/답변 답변을 확실히 받기위한 질문자 지침서 20  
2551 질문/답변 코어 1.8.24 업데이트 후 서버 다운현상 5 2016.08.07 수정 December
2550 질문/답변 xe타운 자게에서 쓰는 경고! 이거 있잖아요... 2 file 2016.08.07 수정 포커스
2549 질문/답변 경험치 모듈 3 2016.08.09 수정 쟈아
2548 질문/답변 갤러리 게시판을 만들고싶은데..해주실분 있으신가요?ㅠㅠ사례합니다.. 1 2016.08.07 수정 도균짱
2547 질문/답변 XE 이미지 파싱후 다운로드해가는거 막는법없을까요 ? 9 2016.08.07 수정 아즈냥
2546 질문/답변 페이스북 oEmbed 잘되시나요? 3 file 2016.08.10 수정 기븐
2545 질문/답변 https -> http 로 이동하는건 없나요? 7 2016.08.06 수정 가브리엘조
2544 질문/답변 상단 메뉴 이동 4 file 2016.08.06 수정 가이더
2543 질문/답변 페이팔 연동질문 2016.08.06 작성 이성민
2542 질문/답변 모바일에서 그룹 이미지 마크 노출방법 4 2016.08.06 수정 메비우스의닭
2541 질문/답변 보유한 폰트파일을 에디터에 적용하려면? 6 2016.08.08 수정 도균짱
2540 질문/답변 누리고 쇼핑몰 트랜드샵 모바일쪽에 이상한 문자열에 대해 질문드립니다. 5 file 2016.08.05 수정 XEMANIA
2539 질문/답변 구글 검색결과.... 1 file 2016.08.05 수정 SimpleCode
2538 질문/답변 다음글이나 이전글 버튼 링크 질문합니다. 2 2016.08.05 수정 SimpleCode
2537 질문/답변 사이트 컨텐츠를 옴기는데 필요한 테이블은 무엇이 있을까요? 3 2016.08.12 수정 torrent
2536 질문/답변 관리자에서 에디터에 들어가지지않습니다 ㅠㅠ 1 file 2016.08.04 수정 misol
2535 질문/답변 xe에는 1:1 문의 게시판은 없나요? 2 2016.08.04 수정 삼삼이
» 질문/답변 라이믹스 '사이트 메뉴 편집'에서 다국어 설정이 풀리는 문제가 있어요 10 file 2016.09.03 수정 데버
2533 질문/답변 이거 왜이런건가요? 1 file 2016.08.04 수정 기진곰
2532 질문/답변 라이믹스에서 ajaxboard 애드온이 작동 안하네요 4 2016.08.05 수정 alrin
Board Pagination Prev 1 ... 40 41 42 43 44 45 46 47 48 49 ... 172 Next
/ 172
위로
서버에 요청 중입니다. 잠시만 기다려 주십시오...