XETOWN

물어보기

ssl 항상 사용시 메인페이지의 사진만 x로 나와요

 

다른곳은 정상적으로 나오는거 같은데 유독 메인페이지만  이미지가 x로 나옵니다.

 

ssl지원애드온 사용하고 있습니다.

 

 

왜 그런걸까요

  • profile
    기진곰 2016.08.18 23:52:12

    https://www.xetown.com/qna/131966 [9번]

  • profile
    pjk 2016.08.18 23:55:08
    아~

    http://nongong.org/
  • profile
    기진곰 2016.08.19 00:11:08
    이미지 주소가 이상하게 나오네요.
    정상: https://nongong.org:10152/xe/.....
    현재: http://nongong.org:10152/xe/.....

    관리자 화면에서 HTTP 포트와 HTTPS 포트를 잘못 입력하셨거나, SSL 지원 애드온의 설정이 잘못되었거나, 이미지 주소를 수동으로 변경하시면서 s를 빼먹으신 것 같습니다.
  • profile
    pjk 2016.08.19 00:19:40
    먼저 늦은시간 감사합니다

    특별히 설정에는 수정한게 없어서요
    이미지들도 모두 그냥 위젯의 썸네일 이미지들 입니다

    ssl지원애드온도 아무런 설정도 한게 없구요 그냥 pc, 모바일에마 체크가 되어져 있습니다.
  • profile
    pjk 2016.08.19 00:20:40
    그런데 이게 http://nongong.org로 접속하면 비정상으로 나오구요
    https://nongong.org/로 접속하면 이미지가 모두 정상으로 나오는거 같아요
  • profile
    기진곰 2016.08.19 00:23:47
    이미지 주소가 모두 //nongong.org:10152 이런 식으로 시작하고 있습니다.
    주소가 이렇게 http도 아니고 https도 아니고 그냥 //로 시작하는 것은 SSL 지원 애드온의 특징입니다.
    애드온 꺼보세요.
  • profile
    pjk 2016.08.19 00:28:25
    감사합니다 해결된거 같습니다.
    늦은시간 도와주셔서 감사합니다. ^^

    제가 ssl을 사용한 이유가 ie8에서도 사용할려고 했는데 지금보니 ie8에서는 애드온유무와 관계없이 ssl을켜면 안되네요
  • profile
    기진곰 2016.08.19 00:39:27
    IE8에서 접속이 안되는 건 XE 쪽 문제가 아니라 서버에 SSL 설치가 잘못된 겁니다.
  • profile
    pjk 2016.08.19 07:54:55
    아.. 접속이 안되는게 아니라... ie 8에서 이미지가 모두 x로 안나오고 또 주소도 이상한 숫자가 중간에 끼여 있어서 보기 안좋아서 사용을 안했는데 이젠 사용을 안할 수가 없게 되어버렸네요 ㅜㅜ

    늦은시간까지 감사했습니다. ^^
  • profile
    pjk 2016.08.19 00:05:51
    원래는 ssl부분사용을 했었는데 이게 얼마전부터 모바일앱에서 부분사용시 회원가입에 문제가 생겨 원인 파악을해보니 ssl부분사용이더라구요 ssl을 제거하던지 항상 사용을 해야하더라구요... 어떻케해야할지 모르겠습니다.

서버에 요청 중입니다. 잠시만 기다려 주십시오...