XE 1.8.29 를 다운받아서 PHP 7.1 과 MySQL 5.5 의 환경에 설치를 시도했는데요. 설치 화면이 뜨지 않고 아래와 같은 에러가 발생합니다. 역시 XE 1.8.x 와 PHP 7.1 은 서로 호환이 되지 않나 봅니다. 어떻게 해결해야 할까요??

 

Fatal error: Uncaught Error: Using $this when not in object context in /.../xe/classes/db/DB.class.php:213 Stack trace: #0 /.../xe/modules/install/install.controller.php(370): DB::getEnableList() #1 /.../xe/modules/install/install.view.php(25): installController->checkInstallEnv() #2 /.../xe/classes/module/ModuleObject.class.php(218): installView->init() #3 /.../xe/classes/module/ModuleHandler.class.php(794): ModuleObject->setModuleInfo(Object(stdClass), Object(stdClass)) #4 /.../xe/index.php(59): ModuleHandler->procModule() #5 {main} thrown in /.../xe/classes/db/DB.class.php on line 213

 

TAG •
  • profile
    Paul 2017.01.18 04:55:13
    PHP 를 7.0 으로 낮춰서 설치를 하니 설치가 됩니다... 설치 후에 다시 PHP 를 7.1 로 올리니 작동에는 이상이 없어 보이네요. ^^;;
  • profile
    람보 2017.01.18 04:59:44
    아직 설치는 안되요.. 라이믹스는 되는데 xe는 아직...ㅋ
  • profile
    Paul 2017.01.18 05:09:21

    그러게요. 같은 환경에서 라이믹스를 설치해 보니 설치가 잘 되네요. ^^

  • profile
    대암지기 2017.01.18 19:15:31

    xe-1.8.27 버전 + php-7.1.0 + mysql-5.7.17
    1. "인증세션 DB 사용"을 체크하시면 로그인이 안됩니다.
    2. xe 설치가 안됩니다.

  • profile
    Paul 2017.01.19 04:04:32
    아... 그렇군요. 인증세션 DB 사용을 체크하면 로그인이 안되는 문제도 있군요. 심각하네요. ^^

서버에 요청 중입니다. 잠시만 기다려 주십시오...