조회 수 92 댓글 9

우분투 16.04를 설치하려고 하는데 이 버전은 PHP7이 설치된다고 하더라구요.

 

써트파티 프로그램들간의 호환 문제가 있을 수 있어서 PHP7보다는 PHP 5.6를 설치하려고 하는데

 

우분투 버전을 낮추지 않아도 PHP 5.6 설치가 가능한지 궁금합니다.

 

일반적인 서버라면 상관 없을거라 생각하는데 혹시 가상 서버라 제한이 있나 싶어 문의해 봅니다.

  • profile
    VJT 2017.07.09 17:54:14
    되는걸로 알고 있습니다만..
  • profile
    Chronos 2017.07.09 17:54:31
    감사합니다. ^^
  • profile
    VJT 2017.07.09 18:51:02
    외국 포럼에 비슷한 내용의 글이 있어,
    올려드려요!
    https://askubuntu.com/questions/756181/installing-php-5-6-on-xenial-16-04
  • profile
    Chronos 2017.07.10 07:33:39
    감사요. ^^
  • profile
    기진곰 2017.07.09 19:06:21

    윗분이 알려주신 링크에 나오는 것처럼 ppa:ondrej/php를 사용하면 5.6부터 7.1까지 선택 가능합니다.

    리얼서버나 가상서버나 차이는 없어요.

  • profile
    Chronos 2017.07.10 07:34:11
    그렇군요. 혹시 몰라서 문의해 봤습니다. -a 아는게 없다보니 ㅠ
  • profile
    구미호 2017.07.09 22:13:56
    다른거와 호환이 문제가 될것도 같은데 말이죠...
  • profile
    구미호 2017.07.09 22:16:23
    써드파티 프로그램을 php7 로 맞추는것은 안되나요 ...?
  • profile
    Chronos 2017.07.10 07:35:24
    그런 능력이 없어서요. ㅜㅠ

서버에 요청 중입니다. 잠시만 기다려 주십시오...