물어보기
질문이나 조언(추천, 의견)을 구할 수 있지만, 답변 의무는 그 누구에게도 없습니다. 직접적인 도움요청은 [작업의뢰]를 이용해주세요.
서버관련

phpmyadmin 오류

조회 수 76 댓글 2

20170730.png

 

phpmyadmin 툴에 접속하면 위와 같은 오류 메시지가 있습니다.

무슨 오류인지 몰라 대충 검색해서 

 

https://stackoverflow.com/questions/37002494/php-7-with-phpmyadmin-gives-lots-of-deprecation-notices

 

이런 글이 있길래 시키는대로 다시 설치했습니다.

sudo apt-get remove --purge phpmyadmin php-gettext php-mbstring -y
sudo apt-get autoremove -y
sudo apt-get update
sudo apt-get install phpmyadmin php-gettext php-mbstring -y

중간에 디비가 다 지워지는 줄 알고 식겁했는데 다행히 디비는 남아있네요.

무슨 오류인지 모르겠습니다. ;ㅁ;

다시 설치해도 동일합니다.

Atachment
첨부 1
  • profile
    기진곰 2017.07.30 20:40:38

    php 버전과 php-gettext 버전이 맞지 않는 것 같은데, 기본 패키지라면 굳이 다른 데서 구해다 설치하실 필요는 없고요... 그냥 php.ini에서 E_DEPRECATED를 표시하지 않도록 해보세요.

     

    근데 우분투 16.04 + PHP 7.0 + 기본 phpmyadmin 패키지 설치하면 저런 에러가 나지는 않던데요... php.ini를 건드리셨나 봅니다 ㅎㅎ

  • profile
    이온디 2017.07.30 22:22:28
    새로 phpmyadmin을 다운받아서 다시 업로드하니깐 사라졌습니다;ㅁ;

서버에 요청 중입니다. 잠시만 기다려 주십시오...